Issue with Managed Identity Platform relating to SaaSquatch Hosted Portals and Microsites
Incident Report for SaaSquatch
Resolved
Between approximately 7:58AM and 11:14AM PST on November 23, 2022, SaaSquatch's Managed Identity Service encountered a series of unhandled errors originating from Google Firebase causing disruptions in service affecting Hosted Portal and Microsite logins and registrations for customers that stood up those features with SaaSquatch later than August of 2021.

After a preliminary investigation, our team returned the Managed Identity Service to fully operational by 11:14AM Pacific on November 23, 2022. An in-depth investigation is being conducted and after findings are concluded, there will be steps put in place to monitor any potential repeats of this issue.

We estimate that this affected about eighteen (18) SaaSquatch customers in total, and a Customer Success Manager will be reaching out to those customers individually to update them and answer any questions that may arise.

Edit: An update was made to this status at 1:55PM PST on November 24, 2022 to adjust the date of affected customers to customers with Hosted Portals and Microsites from August 2022 to August 2021, bringing the total count of potentially affected tenants from ten to eighteen. We apologize for any confusion and for the initial inaccurate number published earlier today.
Posted Nov 23, 2022 - 08:00 PST