SaaSquatch Service Issue
Incident Report for SaaSquatch
Resolved
Service issues with the SaaSquatch platform are resolved.

For more details see the following GCP status update: https://status.cloud.google.com/incidents/6PM5mNd43NbMqjCZ5REh

We apologize for any inconvenience this may have caused. Please don’t hesitate to contact support@referralsaasquatch.com if this
Posted Nov 16, 2021 - 15:16 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 15:15 PST
Monitoring
Service issues with the SaaSquatch platform are now tentatively resolved.

Likely evidence points to a GCP outage and our Development team is continuing to investigate to confirm: https://status.cloud.google.com/incidents/6PM5mNd43NbMqjCZ5REh

The latest information about the status of this issue can also be found on our status page.

We apologize for any inconvenience this may have caused. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted Nov 16, 2021 - 10:14 PST
Investigating
We are currently experiencing service issues with the SaaSquatch platform.
Our development team is currently investigating the issue and is working on a resolution in order to restore service ASAP.

The latest information about the status of this issue can also be found on our status page.

We apologize for any inconvenience this may cause. Please don’t hesitate to contact support@referralsaasquatch.com if this raises any questions or concerns.
Posted Nov 16, 2021 - 10:05 PST
This incident affected: REST API, Admin Portal, and Referral Widget / squatch.js Library.