Delay with SaaSquatch for Salesforce
Incident Report for SaaSquatch
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 01:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Syncs from SaaSquatch to Salesforce should be occurring on a regular basis.
Posted Jun 12, 2021 - 18:02 PDT
Identified
We have identified an issue with the job manager used in the Salesforce integration that is preventing enough jobs from running in parallel at the same time. We are developing a hotfix to replace the affected code so that syncs are run more consistently and the backlog is cleared.
Posted Jun 12, 2021 - 15:17 PDT
Investigating
The SaaSquatch for Salesforce integration is processing data syncs slower than normal. This is affecting getting data from SaaSquatch into Salesforce.

Slowdowns appeared to have started around 7:30AM PST.

Note that SaaSquatch forms that write to Salesforce, and data received from Salesforce via Process Builder and Invocable Methods are not affected. It is only affects the background synchronisation of data from SaaSquatch to Salesforce.
Posted Jun 12, 2021 - 13:10 PDT