Delay in events processing

Incident Report for SaaSquatch

Resolved

Events are being normally processed and the backlog has been cleared.
Posted Mar 27, 2022 - 17:04 PDT

Monitoring

A fix has been deployed to production. The backlog has started to be processed. We are monitoring to make sure the backlog is processed properly and that no new data issues are occurring.
Posted Mar 27, 2022 - 15:02 PDT

Identified

We've identified the problem with our events processing. A small number of events are not processing due to an internal error in our database access layer, and that is causing all events in the pipeline to backlog. We are implementing a fix to handle the identified case. Once that fix is deployed, the backlog will start to get cleared.
Posted Mar 27, 2022 - 14:36 PDT

Investigating

Our user event processing pipeline is backlogged. Events are being received and stored but are delayed in their processing.
Posted Mar 27, 2022 - 13:39 PDT
This incident affected: REST API.