SaaSquatch Platform is down
Incident Report for SaaSquatch
Resolved
On initial review SaaSquatch has determined that a large number of database queries received in rapid succession around 6am Pacific time caused the primary SaaSquatch database to become unresponsive.

This influx of queries has been reviewed and it was determined that it was not the result of a malicious action.

SaaSquatch is actively implementing improvements to reduce the chances of a similar issue globally disrupting SaaSquatch systems.

A detailed analysis of the situation is underway and relevant findings will be shared with SaaSquatch clients upon completion of the analysis.
Posted May 03, 2021 - 17:47 PDT
Update
We are no longer experiencing any issues with our services and continue to actively monitor the situation.
Posted May 03, 2021 - 13:13 PDT
Monitoring
A fix has been implemented and we are monitoring the situations. User widgets should now be loading correctly again.
Posted May 03, 2021 - 08:21 PDT
Investigating
At this moment, various components of the SaaSquatch platform including the widget, portal and API are not functioning. We are investigating and will be sure to post updates as they are available.
Posted May 03, 2021 - 07:23 PDT
This incident affected: REST API, Admin Portal, and Referral Widget / squatch.js Library.